$re = '/(?<!\]\(\s)(?<=\s|\(|\[|^)(?:https?:\/\/)?[a-zA-Z0-9]+[a-zA-Z0-9\-_.]*\.[a-z]{2,6}[^\s]*\b/m';
$str = 'www.google.com
[Tagged](www.google.com)
[Tagged]( www.google.com)
[Tagged ](www.google.com)
,googe.com
.google.com
google.com.
f1.f.com
for.real.com
(?<!\\]\\(\\s*)(?<=\\s|\\(|\\[|^)(?:https?:\\/\\/)?[a-zA-Z0-9]+[a-zA-Z0-9\\-_.]*\\.[a-z]{2,6}[^\\s]*\\b
(google.com)
[google.com]
[ex. http://google.com]
for@real.com
in google.com between
longer form https://google.us.edi?34535/534534?dfg=g&fg in between
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);