import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\]\\(\\s)(?<=\\s|\\(|\\[|^)(?:https?:\\/\\/)?[a-zA-Z0-9]+[a-zA-Z0-9\\-_.]*\\.[a-z]{2,6}[^\\s]*\\b";
final String string = "www.google.com\n\n"
+ "[Tagged](www.google.com)\n"
+ "[Tagged]( www.google.com)\n"
+ "[Tagged ](www.google.com)\n\n"
+ ",googe.com\n"
+ ".google.com\n"
+ "google.com.\n\n"
+ "f1.f.com\n"
+ " for.real.com\n"
+ "(?<!\\]\\(\\s*)(?<=\\s|\\(|\\[|^)(?:https?:\\/\\/)?[a-zA-Z0-9]+[a-zA-Z0-9\\-_.]*\\.[a-z]{2,6}[^\\s]*\\b\n"
+ "(google.com)\n"
+ "[google.com]\n"
+ "[ex. http://google.com] \n\n"
+ "for@real.com\n\n"
+ "in google.com between\n"
+ "longer form https://google.us.edi?34535/534534?dfg=g&fg in between\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}