#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z]([a-z]+|\.)\s*){2,3}$"
Local $sString = "John F. Kennedy" & @CRLF & _
"J.F. Kennedy" & @CRLF & _
"John Kennedy" & @CRLF & _
"john kennedy" & @CRLF & _
"J F kennedy" & @CRLF & _
"j f Kennedy" & @CRLF & _
"Jonn F. Kennedy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")