using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z]([a-z]+|\.)\s*){2,3}$";
string input = @"John F. Kennedy
J.F. Kennedy
John Kennedy
john kennedy
J F kennedy
j f Kennedy
Jonn F. Kennedy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}