package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]([a-z]+|\.)\s*){2,3}$`)
var str = `John F. Kennedy
J.F. Kennedy
John Kennedy
john kennedy
J F kennedy
j f Kennedy
Jonn F. Kennedy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}