$re = '/^([A-Z]([a-z]+|\.)\s*){2,3}$/m';
$str = 'John F. Kennedy
J.F. Kennedy
John Kennedy
john kennedy
J F kennedy
j f Kennedy
Jonn F. Kennedy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);