re = /^([A-Z]([a-z]+|\.)\s*){2,3}$/m
str = 'John F. Kennedy
J.F. Kennedy
John Kennedy
john kennedy
J F kennedy
j f Kennedy
Jonn F. Kennedy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end