const regex = /\xFF/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\xFF', 'gm')
const str = `HolaÿMundo
Texto sin el carácter especial.
Aquí hay un Alt+255: ÿ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}