$re = '/\xFF/m';
$str = 'HolaÿMundo
Texto sin el carácter especial.
Aquí hay un Alt+255: ÿ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);