const regex = /(\w+\s+\d+,\d+\s+\d+,\d+\s+)\((\s+\d+\s+)\)(\s+)\((\s+\d+,\d+\s)\)(\s+\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+\\s+\\d+,\\d+\\s+\\d+,\\d+\\s+)\\((\\s+\\d+\\s+)\\)(\\s+)\\((\\s+\\d+,\\d+\\s)\\)(\\s+\\d+)', 'gm')
const str = `IBNR 13,123 1,234 ( 556 ) ( 2,355 ) 934 `;
const subst = `$1$2$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);