re = /(\w+\s+\d+,\d+\s+\d+,\d+\s+)\((\s+\d+\s+)\)(\s+)\((\s+\d+,\d+\s)\)(\s+\d+)/m
str = 'IBNR 13,123 1,234 ( 556 ) ( 2,355 ) 934 '
subst = '$1$2$3$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result