using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^field\s*a\s*\=\s*(\'|\s)(?<fielda>\w+)";
string input = @"field a='app'
field b = '5'
fielda = app
fieldb= 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}