import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^field\\s*a\\s*\\=\\s*(\\'|\\s)(?<fielda>\\w+)";
final String string = "field a='app'\n"
+ "field b = '5'\n"
+ "fielda = app\n"
+ "fieldb= 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}