// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^field\s*a\s*\=\s*(\'|\s)(?<fielda>\w+)").unwrap();
let string = "field a='app'
field b = '5'
fielda = app
fieldb= 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}