re = /^field\s*a\s*\=\s*(\'|\s)(?<fielda>\w+)/m
str = 'field a=\'app\'
field b = \'5\'
fielda = app
fieldb= 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end