package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^field\s*a\s*\=\s*(\'|\s)(?<fielda>\w+)`)
var str = `field a='app'
field b = '5'
fielda = app
fieldb= 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}