# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[^_]*_(\d+).*/\1/gm;t' <<< "chr1_165656237_T_C_b38"