use strict;
my $str = 'chr1_165656237_T_C_b38';
my $regex = qr/^[^_]*_(\d+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";