package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^_]*_(\d+).*`)
var str = `chr1_165656237_T_C_b38`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}