import re
regex = re.compile(r"^[^_]*_(\d+).*", flags=re.MULTILINE)
test_str = "chr1_165656237_T_C_b38"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)