$re = '/^[^_]*_(\d+).*/m';
$str = 'chr1_165656237_T_C_b38';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;