# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^,(]+(?=,|$)|[\w]+\(.*\)(?=,|$))//g;t' <<< "1, 2, 3, add(4, 5, add(6, 7, 8), 9), 10, 11"