import Foundation
let pattern = #"([^,(]+(?=,|$)|[\w]+\(.*\)(?=,|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1, 2, 3, add(4, 5, add(6, 7, 8), 9), 10, 11"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)