#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^,(]+(?=,|$)|[\w]+\(.*\)(?=,|$))"
Local $sString = "1, 2, 3, add(4, 5, add(6, 7, 8), 9), 10, 11"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)