re = /([^,(]+(?=,|$)|[\w]+\(.*\)(?=,|$))/
str = '1, 2, 3, add(4, 5, add(6, 7, 8), 9), 10, 11'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result