using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^,(]+(?=,|$)|[\w]+\(.*\)(?=,|$))";
string substitution = @"";
string input = @"1, 2, 3, add(4, 5, add(6, 7, 8), 9), 10, 11";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}