# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?(World).*$//gm;t' <<< "Hello World, How's it going today? Have a wonderful evening!"