$re = '/^.*?(World).*$/m';
$str = 'Hello World, How\'s it going today? Have a wonderful evening!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;