const regex = /^.*?(World).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(World).*$', 'gm')
const str = `Hello World, How's it going today? Have a wonderful evening!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);