re = /^.*?(World).*$/m
str = 'Hello World, How\'s it going today? Have a wonderful evening!'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result