use strict;
my $str = 'Hello World, How\'s it going today? Have a wonderful evening!';
my $regex = qr/^.*?(World).*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";