# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=^(?:.{4})*$)^JVBER[a-zA-Z0-9\+\/]*={0,3}$"
test_str = ("JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==\n\n"
"JVBERiBUaGlzIG9uZSdzIHNob3J0\n\n"
" NOT A MULTIPLE OF 4\n"
"JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQf==\n\n"
" TOO MANY =\n"
"JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1w====\n\n"
" WRONG STARTING TEXT\n"
"zVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==\n\n"
" STRAY =\n"
"JVBERiBZb3Ugd2V=dCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.