import Foundation
let pattern = #"(?=^(?:.{4})*$)^JVBER[a-zA-Z0-9\+\/]*={0,3}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
JVBERiBUaGlzIG9uZSdzIHNob3J0
NOT A MULTIPLE OF 4
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQf==
TOO MANY =
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1w====
WRONG STARTING TEXT
zVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
STRAY =
JVBERiBZb3Ugd2V=dCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)