#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:semlps/totalsource|sem-totalsource/2017)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\.aspx)?$"
Local $sString = "https://apples.com/sem-totalsource/2017/LearnMoreHRO" & @CRLF & _
"" & @CRLF & _
"https://www.apples.com/sem-totalsource/2017/LearnMoreHRO-ty" & @CRLF & _
"" & @CRLF & _
"https://www.apples.com/sem-totalsource/2017/LearnMorePEO" & @CRLF & _
"" & @CRLF & _
"https://www.apples.com/sem-totalsource/2017/LearnMorePEO-ty" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")