$re = '`(?:semlps/totalsource|sem-totalsource/2017)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\.aspx)?$`mi';
$str = 'https://apples.com/sem-totalsource/2017/LearnMoreHRO
https://www.apples.com/sem-totalsource/2017/LearnMoreHRO-ty
https://www.apples.com/sem-totalsource/2017/LearnMorePEO
https://www.apples.com/sem-totalsource/2017/LearnMorePEO-ty
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);