using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:semlps/totalsource|sem-totalsource/2017)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\.aspx)?$";
string input = @"https://apples.com/sem-totalsource/2017/LearnMoreHRO
https://www.apples.com/sem-totalsource/2017/LearnMoreHRO-ty
https://www.apples.com/sem-totalsource/2017/LearnMorePEO
https://www.apples.com/sem-totalsource/2017/LearnMorePEO-ty
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}