// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:semlps/totalsource|sem-totalsource/2017)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\.aspx)?$").unwrap();
let string = "https://apples.com/sem-totalsource/2017/LearnMoreHRO
https://www.apples.com/sem-totalsource/2017/LearnMoreHRO-ty
https://www.apples.com/sem-totalsource/2017/LearnMorePEO
https://www.apples.com/sem-totalsource/2017/LearnMorePEO-ty
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}