package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:semlps/totalsource|sem-totalsource/2017)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\.aspx)?$`)
var str = `https://apples.com/sem-totalsource/2017/LearnMoreHRO
https://www.apples.com/sem-totalsource/2017/LearnMoreHRO-ty
https://www.apples.com/sem-totalsource/2017/LearnMorePEO
https://www.apples.com/sem-totalsource/2017/LearnMorePEO-ty
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}