#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})"
Local $sString = "http://www.google.gr" & @CRLF & _
"https://www.google.gr" & @CRLF & _
"http://google.gr" & @CRLF & _
"http://www.google.gr/kino" & @CRLF & _
"http://www.google.co" & @CRLF & _
"http://google.co" & @CRLF & _
"http://google.gr" & @CRLF & _
"www.google.gr" & @CRLF & _
"www.google " & @CRLF & _
"http://www.google" & @CRLF & _
"http://google" & @CRLF & _
"www.google#.com" & @CRLF & _
"www.google.com" & @CRLF & _
"www.google-.gr" & @CRLF & _
"www.-google.gr" & @CRLF & _
"www.goo-gle.com" & @CRLF & _
"googel.gr" & @CRLF & _
"www.google.co" & @CRLF & _
"www.com" & @CRLF & _
"www.g.comwww.g.com" & @CRLF & _
"hello.com" & @CRLF & _
".com" & @CRLF & _
"www." & @CRLF & _
"www.google.comwww.google.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")