import re
regex = re.compile(r"(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})", flags=re.IGNORECASE)
test_str = ("http://www.google.gr\n"
"https://www.google.gr\n"
"http://google.gr\n"
"http://www.google.gr/kino\n"
"http://www.google.co\n"
"http://google.co\n"
"http://google.gr\n"
"www.google.gr\n"
"www.google \n"
"http://www.google\n"
"http://google\n"
"www.google#.com\n"
"www.google.com\n"
"www.google-.gr\n"
"www.-google.gr\n"
"www.goo-gle.com\n"
"googel.gr\n"
"www.google.co\n"
"www.com\n"
"www.g.comwww.g.com\n"
"hello.com\n"
".com\n"
"www.\n"
"www.google.comwww.google.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")