using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})";
string input = @"http://www.google.gr
https://www.google.gr
http://google.gr
http://www.google.gr/kino
http://www.google.co
http://google.co
http://google.gr
www.google.gr
www.google
http://www.google
http://google
www.google#.com
www.google.com
www.google-.gr
www.-google.gr
www.goo-gle.com
googel.gr
www.google.co
www.com
www.g.comwww.g.com
hello.com
.com
www.
www.google.comwww.google.com
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}