import re
regex = re.compile(r"(>)(|[^\S\r\n]+)(<\/)", flags=re.DOTALL)
test_str = (" <file> \n"
" <fileType>Mezza</fileType>\n"
" <fileName></fileName>\n"
" <any_other_tag></any_other_tag>\n"
" <any_other_tag> </any_other_tag>\n"
" <segments>0000</segments>\n"
" </file>")
subst = "\\1[!] value does not exist!\\3"
result = regex.sub(subst, test_str)
if result:
print(result)