re = /(>)(|[^\S\r\n]+)(<\/)/
str = ' <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>'
subst = '\\1[!] value does not exist!\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result