#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\*\*([\s\S\w\W\d\D]+)\*\/([\s]+)private \$[\s\S\d\D]*\;"
Local $sString = "/**" & @CRLF & _
"* @var string" & @CRLF & _
"*" & @CRLF & _
"* @ORM\Column(name="var_1", .....)" & @CRLF & _
"*/" & @CRLF & _
"private $var1;" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
"*blablabla" & @CRLF & _
"*/" & @CRLF & _
"private $test;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")