package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*\*([\s\S\w\W\d\D]+)\*\/([\s]+)private \$[\s\S\d\D]*\;`)
var str = `/**
* @var string
*
* @ORM\Column(name="var_1", .....)
*/
private $var1;
/**
*blablabla
*/
private $test;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}