import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*\\*([\\s\\S\\w\\W\\d\\D]+)\\*\\/([\\s]+)private \\$[\\s\\S\\d\\D]*\\;";
final String string = "/**\n"
+ "* @var string\n"
+ "*\n"
+ "* @ORM\\Column(name=\"var_1\", .....)\n"
+ "*/\n"
+ "private $var1;\n\n"
+ "/**\n"
+ "*blablabla\n"
+ "*/\n"
+ "private $test;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}