use strict;
my $str = '~target~
~target~adjacent is not target~
begining with space ~ target~
ending with space ~target ~
empty ~~
divided by two lines _tar
get_
without closing delimiter ~target
with mixed delimiters ~_target~_
with nested delimiters ~_target_~';
my $regex = qr/(?'a'[~_])(?=
(?'d'(?!\s)(?:(?!\k'a').)+(?<!\s)\k'a') |
(?=(?'b'.*))(?'c'
^(?>\k'a'(?&d)|.)*\k'a'(?&d)(?=\k'b'\z) |
(?<=(?=x^|(?&c)).)
)
)/sxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}