$re = '/(?\'a\'[~_])(?=
(?\'d\'(?!\s)(?:(?!\k\'a\').)+(?<!\s)\k\'a\') |
(?=(?\'b\'.*))(?\'c\'
^(?>\k\'a\'(?&d)|.)*\k\'a\'(?&d)(?=\k\'b\'\z) |
(?<=(?=x^|(?&c)).)
)
)/sx';
$str = '~target~
~target~adjacent is not target~
begining with space ~ target~
ending with space ~target ~
empty ~~
divided by two lines _tar
get_
without closing delimiter ~target
with mixed delimiters ~_target~_
with nested delimiters ~_target_~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);