import re
regex = re.compile(r"""
(?'a'[~_])(?=
(?'d'(?!\s)(?:(?!\k'a').)+(?<!\s)\k'a') |
(?=(?'b'.*))(?'c'
^(?>\k'a'(?&d)|.)*\k'a'(?&d)(?=\k'b'\z) |
(?<=(?=x^|(?&c)).)
)
)
""", flags=re.DOTALL | re.VERBOSE)
test_str = ("~target~\n"
"~target~adjacent is not target~\n"
"begining with space ~ target~\n"
"ending with space ~target ~\n"
"empty ~~\n"
"divided by two lines _tar\n"
"get_\n"
"without closing delimiter ~target\n"
"with mixed delimiters ~_target~_\n"
"with nested delimiters ~_target_~")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")