package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/a\/b\/c\/([^\W_]+)(?:_([0-9]+))?\/p1=(.*)\/p2=(.*)\/p3=(.*)\/(.*)`)
var str = `/a/b/c/d_9000/p1=<val1>/p2=<val2>/p3=<val3>/<val4>
/a/b/c/d/p1=<val1>/p2=<val2>/p3=<val3>/<val4>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}